Discover Network - Potential Failed Transactions
Incident Report for Constellation Payments
Resolved
This incident was resolved by Discover last night.
Posted Feb 07, 2023 - 09:12 EST
Update
Discover is continuing to troubleshoot this issue but does not currently have an estimated time for resolution. We will continue to provide updates as they are given.
Posted Feb 06, 2023 - 17:44 EST
Investigating
Discover has informed World Pay and Elavon of an issue in one of their datacenters that may cause transaction failures. We will continue to monitor and provide updates as Discover provides them.
Posted Feb 06, 2023 - 15:32 EST
This incident affected: Real Time Processing API, Batch Processing, and Terminals.