Terminal Connection Issue
Incident Report for Constellation Payments
Resolved
Processing on terminals has resumed. We will continue to monitor the environment while we investigate the root cause of the issue. Please let us know if you have any further issues.
Posted Dec 10, 2021 - 12:16 EST
Investigating
We are currently investigating an issue with Terminals.
Posted Dec 10, 2021 - 11:35 EST
This incident affected: Terminals.